I am having trouble with some of the tools in my class. What should I do?
Posted by Jason Grizzle on 23 July 2012 03:23 PM

Be sure you are using the latest version of Firefox as your web browser and the latest version of the Java plug-in. You can download from these sites: 

Firefox -

Java -

Georgia Department of Education